Задать вопрос
6 января, 09:49

Составьте алгоритм, который в последовательности натуральных чисел а1, а2, а3 определяет сумму чисел кратных 5. Блок-схему нужно

+2
Ответы (1)
  1. 6 января, 10:31
    0
    Var

    a:array[1 ... 100000] of integer;

    i, max, n:integer;

    begin

    Readln (n) ;

    for i: = 1 to n do

    read (a[i]) ;

    max:=a[1]+a[n];

    for i: = 2 to n div 2 do

    if max < a[i] + a[n-i] then

    max: = a[i] + a[n-i];

    Writeln (max) ;

    end.

    вроде так
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте алгоритм, который в последовательности натуральных чисел а1, а2, а3 определяет сумму чисел кратных 5. Блок-схему нужно ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (2)
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегдаимеется число, кратное 6.
Ответы (1)