Задать вопрос
10 февраля, 04:32

Составить программу по условию: дан массив из 10 элементов. Найти сумму элементов, кратных 3 и двузначных. Массив задан случайно

на паскале

+1
Ответы (1)
  1. 10 февраля, 08:29
    0
    Так как задание не формализовано выводит последовательно суммы кратных 3 и двухзначных чисел

    Program TZ5;

    const

    n=10;

    var

    a:array [1 ... n] of integer;

    i, b:integer;

    begin

    randomize;

    for i:=1 to n do begin

    a[i]:=random (20) ;

    a[i]:=a[i]-10;

    writeln (i,' ', a[i]) ;

    end;

    b:=0;

    for i:=1 to n do

    if (a[i] mod 3) = 0 then

    b:=b+a[i];

    writeln ('summa kratnyh 3m=', b) ;

    b:=0;

    for i:=1 to n do

    if abs (a[i]) >9 then b:=b+a[i];

    writeln ('summa dvuhznachnyh = ', b) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу по условию: дан массив из 10 элементов. Найти сумму элементов, кратных 3 и двузначных. Массив задан случайно на паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2) Задан массив из 11 целых чисел. Посчитать количество нечётных элементов массива. 3) задан массив из 9 целых чисел. Вывести на экран чётные элементы
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)