Задать вопрос
31 июля, 23:46

Вася купил себе новую квартиру и теперь занимается переездом. У него есть N книг, Вася хочет перевозить их отдельно от основных вещей. Для транспортировки он может использовать коробки, которые вмещают M книг каждая. Помогите Васе, какое кол-во коробок ему понадобится для перевозки всех книг за один раз. Составить программу на Паскале или другом ЯП

+4
Ответы (1)
  1. 1 августа, 02:36
    0
    a - количество коробок

    program one;

    var N, M, a : integer;

    begin

    read (N, M) ;

    if N mod M > 0 then

    begin

    a : = (N div M) + 1;

    end;

    if N mod M = 0 then

    begin

    a : = N div M;

    end;

    write (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вася купил себе новую квартиру и теперь занимается переездом. У него есть N книг, Вася хочет перевозить их отдельно от основных вещей. Для ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Назови одним словом. - Легковой автомобиль для перевозки пассажиров. - Автомобиль для перевозки грузов. - Судно для перевозки пассажиров. - Судно для перевозки нефти. - Судно для ловли рыбы. - Поезд для перевозки пассажиров.
Ответы (1)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)
Помогите написать программу в паскале я пытался не получилось. Имеется 2 коробки с конфетами. Вес первой коробки - а, второй - b. Напишите программу, которая определяет какая коробка тяжелее и выводит на экран номер этой коробки и её вес.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
У нас имеется неограниченное кол-во монет достоинством 2, 7 и 10 он хочет заплатить в точности 48. Какое минимальное кол-во монет ему понадобится?
Ответы (1)