Задать вопрос
17 июня, 00:45

Задание на паскале

Дан численный массив M, элементы которых упорядочены по возрастанию и число a. Не нарушая порядок возрастания элементов включить число a в массив M.

+3
Ответы (1)
  1. 17 июня, 04:17
    0
    const n=11;

    var b:array[ 1 ... n] of integer;

    i, j, c, a:integer;

    begin

    randomize;

    for i:=1 to n-1 do begin

    b[i]:=random (50) ;

    write (b[i]:3) ;

    end;

    writeln;

    for i:=1 to n-2 do

    for j:=n-2 downto i do

    if b[j]>b[j+1 ] then begin

    c:=b[j];

    b[j]:=b[j+1];

    b[j+1]:=c;

    end;

    writeln;

    writeln ('Введите число а') ;

    read (a) ;

    writeln ('a = ', a) ;

    b[n]:=a;

    for i:=1 to n do

    write (b[i]:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задание на паскале Дан численный массив M, элементы которых упорядочены по возрастанию и число a. Не нарушая порядок возрастания элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Дан массив X (N, M). Найти номер тех строк массива, элементы которых упорядочены по возрастанию. Сделать в паскале
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)