Задать вопрос
18 мая, 20:12

1. Написать программу, которая определяет наибольшее отрицательное целое число в массиве из 10 элементов.

Значения элементов массива вводятся пользователем.

2. Написать программу, которая определяет наибольшее по модулю число в массиве из 10 введенных пользователем чисел.

+4
Ответы (1)
  1. 18 мая, 21:20
    0
    1.

    var

    mas: array[0 ... 10] of Integer;

    i, min, j: Integer;

    begin

    min:=0;

    writeln ('Введите числа:') ;

    for i : = 1 to 10 do begin

    ReadLn (mas[i]) ;

    if (mas[i] <0)

    then j:=mas[i];

    if j then min:=j;

    end;

    WriteLn ('Минимальное отрицательное число:', min) ;

    end.

    2.

    var

    mas: array [0 ... 10] of Integer;

    i, max, j: Integer;

    begin

    writeln ('Введите числа:') ;

    for i : = 1 to 10 do

    begin

    ReadLn (mas[i]) ;

    if abs (mas[i - 1]) < abs (mas[i]) then

    max : = mas[i];

    end;

    WriteLn ('Наибольшее по модулю число:', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Написать программу, которая определяет наибольшее отрицательное целое число в массиве из 10 элементов. Значения элементов массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
Создать два одномерных массива, состоящих из целых чисел. Элементы массива вводятся с клавиатуры. В первом массиве найти номер первого нечетного элемента массива. Во втором массиве найти первый четный элемент массива.
Ответы (1)