Задать вопрос
9 февраля, 17:15

Помогите написать на Паскале

Дано N пицц Пиццу резать нельзя! Если распределить пиццы поровну среди М друзей, то по скольку пицц получит каждый друг и сколько пицц окажутся не распределенными? Программа получает на вход два натуральных числа N и M, при чем N > M. N не превосходит 10 9 Программа должна вывести два числа - сколько пицц достанется каждому другу и сколько пицц останется не распределенными через пробел

+5
Ответы (1)
  1. 9 февраля, 17:42
    0
    До нельзя просто. div находит целое число от деления, mod - остаток. Путём деления и находим, кто сколько пицц скушает =)

    program Pizza2friends;

    var N, M:integer;

    begin

    writeln ('Введите количество пицц') ;

    read (N) ;

    writeln ('Введите количество друзей') ;

    read (M) ;

    if N > M then

    writeln ('У каждого друга будет ', N div M,' пицц. Останется ', N mod M,' ничьих пицц.')

    else writeln ('Пицц должно быть больше, чем друзей') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать на Паскале Дано N пицц Пиццу резать нельзя! Если распределить пиццы поровну среди М друзей, то по скольку пицц получит ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
N школьников делят k яблок поровну, неделящийся остаток остается в корзинке. Сколько яблок достанется каждому школьнику? Сколько яблок останется в корзинке? Программа получает на вход числа n и k и должна вывести искомое количество яблок (два числа).
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)