Задать вопрос
29 января, 17:37

N школьников делят k яблок поровну, неделящийся остаток остается в корзинке. Сколько яблок достанется каждому школьнику? Сколько яблок останется в корзинке? Программа получает на вход числа n и k и должна вывести искомое количество яблок (два числа).

+3
Ответы (1)
  1. 29 января, 20:22
    0
    Program sh;

    var n, k: integer;

    begin

    write ('введите кол-во школьников: ') ;

    readln (n) ;

    write ('введите кол-во яблок: ') ;

    readln (k) ;

    writeln ('останется в корзинке: ', k mod n) ;

    writeln ('достанется каждому по ', k div n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «N школьников делят k яблок поровну, неделящийся остаток остается в корзинке. Сколько яблок достанется каждому школьнику? Сколько яблок ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Из N школьников делят K и персиков поровну, неделящийся остаток остается в корзинке. Сколько персиков останется в корзинке? Программа получает на вход числа N И и И K и должна вывести искомое количество персиков. Язык C.
Ответы (1)
Задача "Дележ яблок" Условие n школьников делят k яблок поровну, неделящийся остаток остается в корзинке.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)