Задать вопрос
26 октября, 10:09

Сколько различных значений числа d можно ввести, чтобы после выполнения программы было напечатано 69?

var n, s, d: integer;

begin

readln (d) ;

n : = 14;

s : = 29;

while s < = 2000 do begin

s : = s + d;

n : = n + 5

end;

write (n)

end.

+2
Ответы (1)
  1. 26 октября, 12:37
    0
    Можно ввести 18 значений от 180 до 197.

    Из программы видно, что 14+k*5 = 69 = > k = 11

    29 + k*d > = 2000, отсюда получаем минимальное значение d

    d = 1971/11 = 179,18, но так как d - целое, то d min = 180.

    Максимальное значение d из условия: d max = (1999-29) / 10 = 197
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сколько различных значений числа d можно ввести, чтобы после выполнения программы было напечатано 69? var n, s, d: integer; begin readln ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы