Задать вопрос
14 января, 21:46

С++

Напишите программу, которая заменяет во всей строке одну последовательность символов на другую.

Пример:

Введите строку:

(X > 0) and (Y Y) and (Z 5)

Что меняем: and

Чем заменить: &

Результат

(X > 0) & (Y Y) & (Z 5)

+3
Ответы (1)
  1. 14 января, 23:34
    0
    Красивый ввод/вывод сам добавишь

    //Microsoft (R) C/C + + Optimizing Compiler Version 19.00.23506 for x64

    #include

    #include

    using namespace std;

    int main ()

    {

    string str, from, to;

    getline (cin, str) ;

    cin >> from >> to;

    size_t i = 0;

    for (; (i = str. find (from, i)) ! = string::npos; i + = to. length ())

    str. replace (i, from. length (), to) ;

    cout << str;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С++ Напишите программу, которая заменяет во всей строке одну последовательность символов на другую. Пример: Введите строку: (X > 0) and (Y ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
У Вити имеются три одинаковых непрозрачных пластиковых стакана. Он расставил их перед собой и написал чисола к1 к 2 к3 соотвественно на левом средном правом стаканах Патом витя придумал такой алгоритм перемещения стаканов меняем местами левый и
Ответы (1)
Написать программу в лазарусе. Дана строка. Написать программу, которая находит и заменяет во всей строке цифры от 0 до 9 на слова "ноль", "один", ... "девять". Преобразованную строку вывести на екран.
Ответы (1)
Помогите решить две задичи Задача: Написать программу, которая а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран б) удаляет все буквы 'а' из строки и выводит новую строку на экран
Ответы (1)
Напишите функцию, которая заменяет расширение файла на заданное новое расширение. Пример: Введите имя файла qq; Введите новое расширение: tmp; Результат: qq. tmp
Ответы (1)
1) Сколько символов в тексте, если 1) Сколько символов в тексте, если мощность алфавита-64 символа, а объем информации, содержащийся в нем-1,5 Кбайт. 2) Сообщение занимает 3 страницы по 25 строк. В каждой строке записано по 60 символов.
Ответы (1)