Задать вопрос
3 февраля, 03:49

Написать программу в лазарусе. Дана строка. Написать программу, которая находит и заменяет во всей строке цифры от 0 до 9 на слова "ноль", "один", ... "девять". Преобразованную строку вывести на екран.

+2
Ответы (1)
  1. 3 февраля, 07:36
    0
    Var

    S:string;

    i:integer;

    begin

    ReadLn (S) ;

    i:=1;

    While i<=Length (S) do

    Begin

    if ('0'<=S[i]) and (S[i]<='9') then

    Case S[i] of

    '0':

    Begin

    Delete (S, i, 1) ;

    Insert ('ноль', S, i) ;

    end;

    '1':

    Begin

    Delete (S, i, 1) ;

    Insert ('один', S, i) ;

    i:=i+3

    end;

    '2':

    Begin

    Delete (S, i, 1) ;

    Insert ('два', S, i) ;

    i:=i+2

    end;

    '3':

    Begin

    Delete (S, i, 1) ;

    Insert ('три', S, i) ;

    i:=i+2

    end;

    '4':

    Begin

    Delete (S, i, 1) ;

    Insert ('четыре', S, i) ;

    i:=i+5

    end;

    '5':

    Begin

    Delete (S, i, 1) ;

    Insert ('пять', S, i) ;

    i:=i+3

    end;

    '6':

    Begin

    Delete (S, i, 1) ;

    Insert ('шесть', S, i) ;

    i:=i+4

    end;

    '7':

    Begin

    Delete (S, i, 1) ;

    Insert ('семь', S, i) ;

    i:=i+3

    end;

    '8':

    Begin

    Delete (S, i, 1) ;

    Insert ('восемь', S, i) ;

    i:=i+5

    end;

    '9':

    Begin

    Delete (S, i, 1) ;

    Insert ('девять', S, i) ;

    i:=i+5

    end;

    end;

    i:=i+1

    End;

    WriteLn (S) ;

    ReadLn;

    end.

    Для того, чтобы данная программа заработала, нажмите: Файл → создать → простейшая программа.

    Если русские буквы отображаются правильно, нажмите правой кнопкой мыши по коду, выберите: параметры файла → кодировка → Ansi (cp1251).
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в лазарусе. Дана строка. Написать программу, которая находит и заменяет во всей строке цифры от 0 до 9 на слова "ноль", ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Pascal ABC Дана строка, состоящая из маленьких английских букв и цифр. Удалить гласные буквы в конце строки от последней не гласной буквы или цифры (конечные гласные буквы). Вывести преобразованную строку и количество удаленных символов
Ответы (1)
Введите строку. Преобразуйте строку таким образом, чтобы после каждой цифры "2" стояли три символа "!" Выведите преобразованную строку на экран. Pascal
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)