Задать вопрос
25 февраля, 02:49

Мир охватила эпидемия воспаления хитрости! Ученым удалось выделить ДНК из трех вероятно зараженных клеток.

ДНК каждой из клеток состоит из последовательности азотистых оснований, каждое из которых закодировано буквой A, G, T или C. Вирус также описывается последовательностью азотистых оснований и эта последовательность встраивается в произвольное место ДНК клетки.

Чтобы выделить вирус, необходимо найти самую длинную последовательность подряд идущих азотистых оснований, которая встречается в ДНК всех трех зараженных клеток.

Формат входных данных

Во входных данных задается три строки, состоящих из символов A, G, T и C, описывающих ДНК зараженных клеток. Длина строк не превосходит 100.

Формат результата

Выведите описание вируса. Если возможных вариантов несколько - выведите любой.

+1
Ответы (1)
  1. 25 февраля, 05:33
    0
    Решал эту штуку на с++.

    И я думаю это самый норм язык для этого, потому что я перебирал

    Кстати, если мой учитель это читает, я сам сделал эту штуку!

    #include

    #include

    #include

    #include

    using namespace std;

    int main ()

    {

    string a, b, c, mi;

    int y = 0;

    cin >> a >> b >> c;

    vector z;

    if (a. length () < = b. length () && a. length () < = c. length ()) {

    mi = a;

    }

    else if (b. length () < = a. length () && b. length () < = c. length ()) {

    mi = b;

    }

    else{

    mi = c;

    }

    for (int i = 1; i < = mi. length () ; i++) {

    y = 0;

    for (int l = 0; l < mi. length () - i + 1; l++) {

    string s;

    for (int j = 0; j < i; j++) {

    s = s + mi[l + j];

    }

    if (a. find (s) ! = std::string::npos && b. find (s) ! = std::string::npos && c. find (s) ! = std::string::npos) {

    z. push_back (s) ;

    y = 1;

    break;

    }

    }

    if (y = = 0) {

    break;

    }

    }

    cout << z[z. size () - 1];

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Мир охватила эпидемия воспаления хитрости! Ученым удалось выделить ДНК из трех вероятно зараженных клеток. ДНК каждой из клеток состоит из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ваня ведёт дневник, где в том числе отмечает, делал он зарядку в этот день или нет. Напишите программу, которая по собранной статистике сообщит, сколько последних дней подряд Ваня делал зарядку, а так же наибольшее число дней подряд когда он делал
Ответы (1)
Задача AДоска Задается N. Нужно вывести цвет каждой клетки доски N x N, если известно, что они покрашены в шахматном порядке и клетка (1, 1) - белая. Формат входных данных Первая строка входного файла содержит единственное целое N (1 < = N < = 10).
Ответы (1)
Компьютер вирус А заполняет 1 Гбайт за один месяц, вирус В заполняет 1 Гбайт за два месяца, вирус С заполняет 1 Гбайт за три месяца, вирус Д заполняет 1 Гбайт за шесть месяцев. На компьютере одновременно обнаружены сразу все четыре вируса.
Ответы (1)
Компьютерный вирус А заполняет 1 Гб памяти за один месяц, вирус В заполняет 1 Гб за два месяца, вирус С заполняет 1 Гб за три месяца, вирус D заполняет 1 гб за шесть месяцев. На компьютере одновременно обнаружены сразу все четыре вируса.
Ответы (1)
Компьютерный вирус А заполняет 1 Гбайт за один месяц, вирус В заполняет 1 Гбайт за два месяца, вирус С заполняет 1 Гбайт за три месяца, вирус D заполняет 1 Гбайт за шесть месяцев. На компьютере одновременно обнаружены сразу все четыре вируса.
Ответы (1)