Задать вопрос
22 апреля, 21:46

Составить программу которая определяет наличие одинаковых цифр в произвольном 3-значном числе

+1
Ответы (1)
  1. 23 апреля, 00:20
    0
    Var a, a1, a2, a3:integer;

    begin

    readln (a) ;

    a1:=a div 100;

    a2:=a div 10 mod 10;

    a3:=a mod 10;

    if (a1=a2) or (a1=a3) or (a2=a3)

    then writeln ('Одинаковые цифры есть')

    else writeln ('Одинаковых цифр нет') ;

    end.

    Пример:

    121

    Одинаковые цифры есть
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу которая определяет наличие одинаковых цифр в произвольном 3-значном числе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Решить с помощью Паскаля две задачи: 1. Составить программу, которая содержит функцию и которая определяет, верно ли, что сумма цифр числа является четным числом. 2.
Ответы (1)