Задать вопрос
16 сентября, 13:32

Дан массив из 10-ти элементов.

23, 345, 47, 225, 15, 786, 650, 32, 9, 110.

Написать программу, которая находит и выводит на печать сумму четных чисел.

Ответ:

786+650+32+110=1578.

+1
Ответы (1)
  1. 16 сентября, 16:52
    0
    Var a:array of integer : = (23, 345, 47, 225, 15, 786, 650, 32, 9, 110) ;

    i, s:integer;

    begin

    writeln (a) ;

    writeln ('Ответ: ') ;

    for i:=0 to 9 do

    if a[i] mod 2 = 0 then

    begin

    write (a[i]) ;

    s:=s+a[i];

    if i<9 then write (' + ') ;

    if i=9 then write (' = ')

    end;

    write (s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 10-ти элементов. 23, 345, 47, 225, 15, 786, 650, 32, 9, 110. Написать программу, которая находит и выводит на печать сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)