Задать вопрос
15 октября, 19:39

Двухмерные масивы. в целочисленной матрице размерность 10*10 найти сумму положительных элементов четных строк

+1
Ответы (1)
  1. 15 октября, 19:56
    0
    const n=10;

    var a:array [1 ... n, 1 ... n] of integer;

    i, j, s:integer;

    begin

    for i: = 1 to n do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=Random (21) - 10;

    write (a[i, j]:4)

    end;

    writeln;

    end;

    for i: = 1 to n do

    if i mod 2 = 0 then

    for j:=1 to n do

    if a[i, j]>0 then s:=s+a[i, j];

    writeln ('Сумма положительных элементов чётных строк равна: ', s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Двухмерные масивы. в целочисленной матрице размерность 10*10 найти сумму положительных элементов четных строк ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. в целочисленной матрице размерностью 3 х3 найти сумму наибольшего и наименьшего элементов матрицы паскаль 2. дан массив из 10 целых чисел. написать программу нахождения количества четных элементов массива
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Имеется целочисленный массив состоящий из N элементов (N - чётное) а) Найти сумму первых N/2 элементов. б) Найти сумму элементов стоящих на чётных позициях. в) Найти произведение элементов стоящих на нечётных позициях.
Ответы (1)