Задать вопрос
19 февраля, 09:04

1. Составьте программу, определяющую максимальное из всех вводимых вами

чисел. Концом ввода чисел является введенное число 0.

Важно! - нужно сделать через for или while!

+1
Ответы (1)
  1. 19 февраля, 11:30
    0
    Я так полагаю, что это паскаль. Через while будет попроще это сделать.

    Var

    a, b:real;

    Begin

    read (a) ;

    b:=a;

    while a0 do begin

    read (a) ;

    if a>b then b:=a;

    end;

    writeln (b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Составьте программу, определяющую максимальное из всех вводимых вами чисел. Концом ввода чисел является введенное число 0. Важно! - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте и отладьте программу, определяющую максимальное из всех введенных вами чисел. (Пусть признаком конца ввода чисел является введенное число 0.) Используя цикл с постусловием
Ответы (1)
Нужно составить программу с помощью Repeat, определяющую максимальное из всех введённых вами чисел. (Пусть признаком конца ввода чисел является введённое число 0).
Ответы (2)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Составьте программу, определяющую, является ли введенное с клавиатуры целое число кратным 3. Пример ввода: 123 Пример вывода: Число 123 кратно 3
Ответы (1)