Задать вопрос
30 июня, 16:10

Нужно составить программу с помощью Repeat, определяющую максимальное из всех введённых вами чисел. (Пусть признаком конца ввода чисел является введённое число 0).

+2
Ответы (2)
  1. 30 июня, 17:26
    0
    var

    i, e : Integer;

    begin

    Writeln ('Вводите числа:') ;

    i : = 0;

    repeat

    Readln (e) ;

    if e > i then i : = e;

    until e = 0;

    Writeln ('Наибольшее число: ', i) ;

    end.
  2. 30 июня, 18:46
    0
    Program abc;

    uses crt;

    const n=30;

    var

    a:array[1 ... n] of integer;

    i, max:integer;

    begin

    clrscr;

    for i:=1 to n do

    read (a[i]) ;

    max:=a[1];

    for i:=2ton do

    if a[i]>max then max:=a[i];

    write ('max=', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно составить программу с помощью Repeat, определяющую максимальное из всех введённых вами чисел. (Пусть признаком конца ввода чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте и отладьте программу, определяющую максимальное из всех введенных вами чисел. (Пусть признаком конца ввода чисел является введенное число 0.) Используя цикл с постусловием
Ответы (1)
1. Составьте программу, определяющую максимальное из всех вводимых вами чисел. Концом ввода чисел является введенное число 0. Важно! - нужно сделать через for или while!
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Составьте программу, определяющую, является ли введенное с клавиатуры целое число кратным 3. Пример ввода: 123 Пример вывода: Число 123 кратно 3
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)