Задать вопрос
12 сентября, 18:29

Помогите написать программу (Pascal ABC)

Программирование циклических алгоритмов.

Дано натуральное число N. Вычислить

S=1+1/3+1/5+1/7 + ... + 1/2N+1

+3
Ответы (1)
  1. 12 сентября, 18:43
    0
    Var n, i:integer; s:real;

    begin

    readln (n) ;

    s:=0;

    for i:=0 to n do s:=s+1 / (2*i+1) ;

    writeln ('s = ', s) ;

    end.

    Пример:

    5

    s = 1.878210678210678e+00
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу (Pascal ABC) Программирование циклических алгоритмов. Дано натуральное число N. Вычислить S=1+1/3+1/5+1/7 + ... ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программирование циклических алгоритмов. Программирование циклов с заданнымусловием продолжения работы. Задача: Клиент открыл счет в банке в 2017 году, вложив 1000 рублей.
Ответы (1)
Составление циклических алгоритмов. Использование оператора цикла с постусловием repeat ... until. Найти наименьшее натуральное число, дающее при делении на 2, 3, 4, 5, 6 соответственно остатки 1, 2, 3, 4, 5.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
1. С клавиатуры вводится 3 числа. Найти сумму только из положительных чисел. (Тема: Программирование ветвлящихся и цепленных алгоритмов) 2. Дано двухзначное число, найти сумму и произведение его чисел.
Ответы (1)