Задать вопрос
4 мая, 09:19

Составить программу для паскаля

даны три стороны треугольника, определить является ли такой треугольник равнобедренным, равносторонним или произвольным

+4
Ответы (1)
  1. 4 мая, 11:26
    0
    Var a, b, c: integer;

    begin

    write ('Введите сторону а: ') ;

    read (a) ;

    write ('Введите сторону b: ') ;

    read (b) ;

    write ('Введите сторону c: ') ;

    read (c) ;

    if (a=b) and (b=c) then

    writeln ('Треугольник равносторонний')

    else if (a=b) or (b=c) or (a=c) then

    writeln ('Треугольник равнобедренный')

    else writeln ('Треугольник произвольный') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для паскаля даны три стороны треугольника, определить является ли такой треугольник равнобедренным, равносторонним или ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны три стороны треугольника. определить существует ли треугольник с заданными сторонами, если да, то определить является ли он прямоугольным, равнобедренным или равносторонним, какой треугольник тупоугольный или остроугольный.
Ответы (1)
Даны 3 стороны треугольника. написать алгоритм и программу определяющую является ли этот треугольник равнобедренным (но не равносторонним).
Ответы (1)
Запросить стороны треугольника и определить, является ли он разносторонним, равносторонним или равнобедренным. Учесть: третья сторона не должна превышать сумму двух других, иначе треугольник не существует.
Ответы (1)
Написать программу существования треугольника по заданным длинам сторон, используя if, else. Является треугольник равносторонним и равнобедренным
Ответы (1)
1) Ввести с клавиатуры целое число. Определить четное оно, или нечетное. 2) Решить следующие задачи: Является ли треугольник с длинами сторон a, b, c: * прямоугольным; * равнобедренным; * равносторонним. Стороны вводятся с клавиатуры.
Ответы (1)