Задать вопрос
30 августа, 20:33

Если можно, через циклы

Вводятся действительные a и x и натуральное n. Вычислить Y Y = x + x^3/3 + x^5/5 + ... + x^2n-1 / (2n-1).

+4
Ответы (1)
  1. 30 августа, 21:57
    0
    Var x, xn, y:real; n, i:integer;

    begin

    readln (x) ;

    readln (n) ;

    xn:=x;

    y:=x;

    for i:=2 to n do

    begin

    xn:=xn*x*x;

    y:=y+xn / (2*i-1) ;

    end;

    writeln (y:5:3) ;

    end.

    Пример:

    1.8

    5

    38.309
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Если можно, через циклы Вводятся действительные a и x и натуральное n. Вычислить Y Y = x + x^3/3 + x^5/5 + ... + x^2n-1 / (2n-1). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите по инфе с заданиями на циклы: 1. Вводятся 15 чисел, сколько из них удовлетворяют условиям нечетное и кратно 7 2. Вводятся 10 чисел, найдите их сумму
Ответы (1)
5. Алгоритм, не реализующий обратную связь 1) может содержать циклы и ветвления 2) может содержать циклы 3) может быть только циклическим 4) может быть только линейным 5) может содержать ветвления 6) пропустить
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
Задания по Pascal №1 найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B. A и B вводятся с клавиатуры. №2 найти сумму всех чисел из промежутка от A до B, кратных 5. A и B вводятся с клавиатуры.
Ответы (1)