Задать вопрос
7 января, 10:18

Составьте программу, которая формирует массив из 11 случайных целых чисел от - 10 до 5 и все положительные элементы возводит в квадрат

+2
Ответы (1)
  1. 7 января, 10:34
    0
    Var

    i, s:integer;

    a:array [1 ... 11] of integer;

    begin

    randomize;

    writeln ('Chislo: ','Chislo v kvadrate') ;

    for i:=1 to 11 do

    begin

    a[i]:=Random (15) - 10;

    write (a[i]:4) ; writeln (sqr (a[i]) : 15) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая формирует массив из 11 случайных целых чисел от - 10 до 5 и все положительные элементы возводит в квадрат ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая формирует массив из 15 случайных чисел вдиапазоне от 15 до - 15 и: 1) отрицательные числа заменяет наих модули, а неотрицательные возводит в квадрат 2) четные числа заменяет на 2, а от нечетных - отнимает 5 3) числа,
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Cоставить программу, которая формирует массив из 16 случайных целых чисел от - 20 до 20 и выводит элементы, кратные 3. На экран выводится исходный массив и найденные элементы.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Составте программу, котороя формирует массив из 16 случайных целых чисел от - 10 до 10 и находит элементы с нулевыми значениями. На экран выводятся исходных массив и найденные элементы.
Ответы (2)