Задать вопрос
11 мая, 05:23

Cоставить программу, которая формирует массив из 16 случайных целых чисел от - 20 до 20 и выводит элементы, кратные 3. На экран выводится исходный массив и найденные элементы.

+5
Ответы (1)
  1. 11 мая, 08:04
    0
    Const n=16;

    var a:array[1 ... n] of integer;

    i:integer;

    begin

    for i:=1 to n do begin

    a[i]:=random (40) - 20;

    write (a[i], ' ') ;

    end;

    writeln;

    for i:=1 to n do

    if (a[i] mod 3) = 0 then write (a[i], ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Cоставить программу, которая формирует массив из 16 случайных целых чисел от - 20 до 20 и выводит элементы, кратные 3. На экран выводится ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Составте программу, котороя формирует массив из 16 случайных целых чисел от - 10 до 10 и находит элементы с нулевыми значениями. На экран выводятся исходных массив и найденные элементы.
Ответы (2)
Составьте программу, которая заполнит массив a[1 ... 16]случайными целыми числами в диапазоне от - 20 до 20, выводит на экран исходный массив, затем преобразовывает его, увеличивая в 2 раза все числа, кратные 5, а остальные уменьшает на 10.
Ответы (1)
Составьте программу (в паскале), которая заполнит массив a[1 ... 16]случайными целыми числами в диапазоне от - 20 до 20, выводит на экран исходный массив, затем преобразовывает его, увеличивая в 2 раза все числа, кратные 5, а остальные уменьшает на
Ответы (1)