Задать вопрос
3 ноября, 03:28

Составьте программу (в паскале), которая заполнит массив a[1 ... 16]случайными целыми числами в диапазоне от - 20 до 20, выводит на экран исходный массив, затем преобразовывает его, увеличивая в 2 раза все числа, кратные 5, а остальные уменьшает на 10. Затем выводит на экран преобразованный массив.

+4
Ответы (1)
  1. 3 ноября, 06:49
    0
    const n=16;

    var a:array [1 ... n] of integer;

    i:integer;

    begin

    for i:=1 to n do a[i]:=random (41) - 20;

    writeln ('Исходный массив: ') ;

    for i:=1 to n do write (a[i]:5) ;

    writeln;

    for i:=1 to n do

    if a[i] mod 5 = 0 then a[i]:=a[i]*2 else a[i]:=a[i]-10;

    writeln ('Преобразованный массив: ') ;

    for i:=1 to n do write (a[i]:5)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу (в паскале), которая заполнит массив a[1 ... 16]случайными целыми числами в диапазоне от - 20 до 20, выводит на экран ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая заполнит массив a[1 ... 16]случайными целыми числами в диапазоне от - 20 до 20, выводит на экран исходный массив, затем преобразовывает его, увеличивая в 2 раза все числа, кратные 5, а остальные уменьшает на 10.
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)