Задать вопрос
16 июня, 18:47

Составить программу на языке Паскаль Ввести с клавиатуры вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N.

+4
Ответы (2)
  1. 16 июня, 19:56
    0
    Var a, an:real; n, i:integer;

    begin

    readln (a, n) ;

    an:=1;

    for i:=1 to n do

    begin

    an:=an*a;

    writeln (a:3:2,'^', i,' = ', an:6:3) ;

    end;

    end.

    Пример:

    2.0 5

    2.00^1 = 2.000

    2.00^2 = 4.000

    2.00^3 = 8.000

    2.00^4 = 16.000

    2.00^5 = 32.000
  2. 16 июня, 20:23
    0
    Var

    a: real;

    n: integer;

    begin

    read (a, n) ;

    for var k : = 1 to n do

    begin

    write (power (a, k), ' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на языке Паскаль Ввести с клавиатуры вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
через паскаль 1 ввести 3 числа, вывести наименьшее 2 ввести номер месяца, вывести название месяца 3 ввести 5 чисел, вывести в порядке убывания
Ответы (1)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
1) ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент
Ответы (1)