Задать вопрос
25 августа, 01:20

Необходимо написать программу, которая вычислит сумму 1+1/3+1/3^2 + ... + 1/3^n на языке C++, используя цикл for

+2
Ответы (1)
  1. 25 августа, 02:45
    0
    Microsoft VS 2017 (C++)

    #include

    using namespace std;

    double find (int n) {

    double rez = 1.;

    for (int i = 1; i < = n; i++) {

    rez + = 1 / pow (3, i) ;

    }

    return rez;

    }

    int main () {

    int n; cin >> n;

    cout << find (n) << endl;

    system ("pause") ; / / если не компилируется, поменяй эту строку / / на getchar ()

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Необходимо написать программу, которая вычислит сумму 1+1/3+1/3^2 + ... + 1/3^n на языке C++, используя цикл for ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием.
Ответы (1)
1) Напишите программу, которая вводит натуральное число N и нахо дит сумму всех натуральных чисел от 1 до N. Используйте сначала цикл с условием, а потом - цикл с переменной.
Ответы (1)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Факториалом числа 5 (обозначается 5!) называется значение следующего выражения: f=1*2*3*4*5. Составьте программу, которая запросив у пользователя целое число n, вычислит значение факториала числа. (Линейное программирование, цикл с параметром)
Ответы (1)