Задать вопрос
9 сентября, 16:19

В вещественном массиве размером 30 элементов задан вес спортсменок одной команды (в килограммах с округлением до десятых). Опишите на русском языке или на одном из языков программирования алгоритм подсчёта количества спортсменок, чей вес превышает 50 кг, но не более 57 кг. Если таких спортсменок нет, то сообщите об этом

+1
Ответы (1)
  1. 9 сентября, 18:10
    0
    int main () {

    int a[30] = {45, 42, 33, 54, 55, 56, 57, 58, 59, 54, 45, 42, 33, 54, 55, 56, 57, 58, 59, 54, 45, 42, 33, 54, 55, 56, 57, 58, 59, 54};

    int n=0;

    for (int i=0; i<30; i++) {

    if ((a[i]>50) && (a[i]<=57)) {n++; }

    }

    printf ("%d ", n) ; n - количество спортсменок с нужным весом

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В вещественном массиве размером 30 элементов задан вес спортсменок одной команды (в килограммах с округлением до десятых). Опишите на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Опишите на русском языке или одном из языков программирования алгоритм подсчета суммы произведений последовательных пар элементов в целочисленном массиве из 30 элементов.
Ответы (1)
2) Опишите на русском языке или одном из языков программирования алгоритм подсчета максимального количества подряд идущих отрицательных элементов в целочисленном массиве длины 30. На Паскале АБС
Ответы (1)
1. Напишите алгоритм подсчета числа элементов, равных максимальному, в числовом массиве из 30 элементов. 2. Напишите алгоритм поиска трех последовательных элементов, сумма которых максимальна, в числовом массиве из 30 элементов.
Ответы (1)
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Решение есть. нужно его объяснить. Опишите на русском языке или на одном из языков программирования алгоритм вычисления разности максимального среди элементов, имеющих четные значения, и максимального среди элементов имеющих нечетные значения, в
Ответы (1)