Задать вопрос
31 марта, 13:28

Посчитать, сколько в массиве из 10 элементов четных чисел. Элементы массива вводятся с клавиатуры.

+3
Ответы (1)
  1. 31 марта, 13:42
    0
    Var

    A: array [1 ... 10] of integer;

    i, count : byte;

    begin

    count : = 0;

    for i : = 1 to 10 do

    begin

    write ('Введите A[', i, '] = ') ;

    readln (A[i]) ;

    if A[i] mod 2 = 0 then

    count : = count + 1;

    end;

    for i : = 1 to 10 do

    write (A[i]:4) ;

    writeln;

    writeln ('Количество четных элементов = ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Посчитать, сколько в массиве из 10 элементов четных чисел. Элементы массива вводятся с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Создать два одномерных массива, состоящих из целых чисел. Элементы массива вводятся с клавиатуры. В первом массиве найти номер первого нечетного элемента массива. Во втором массиве найти первый четный элемент массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)