Задать вопрос
6 августа, 19:31

Пользователь вводит числа до тех пор, пока она в сумме не дадут число, кратное трем и оканчивающиеся на 3. После чего выводится сообщение о выигрыше в размере среднего арифметического введенных чисел.

Решить с помощью динамического массива, в Paskal.

+3
Ответы (1)
  1. 6 августа, 21:16
    0
    Var a, s, k: integer;

    sr: real;

    begin

    k:=0; s:=0;

    repeat

    readln (a) ;

    s:=s+a;

    k:=k+1;

    until (s mod 10 = 3) and (s mod 3 = 0) ;

    sr:=round ((s/k) * 100) / 100;

    writeln ('Выигрыш: ', sr) ;

    end.

    17

    28

    10

    8

    Выигрыш: 15.75
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Пользователь вводит числа до тех пор, пока она в сумме не дадут число, кратное трем и оканчивающиеся на 3. После чего выводится сообщение о ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ребят, помоги в паскале. напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. В конце работы программы на экран выводится сумма и произведение введенных чисел.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36).
Ответы (1)
С клавиатуры пользователь вводит числа до тех пор, пока не будет введен 0. вычислите сумму введенных чисел
Ответы (1)
Дан одновременный массив, состоящий из 10 эллементов. Пользователь вводит элементы массива. Ввести массив на экран в строку. Найти минимальный элемент массива.
Ответы (1)