Задать вопрос
10 сентября, 11:39

Ребят, помоги в паскале. напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. В конце работы программы на экран выводится сумма и произведение введенных чисел.

+4
Ответы (1)
  1. 10 сентября, 12:06
    0
    Var a, s, p:integer;

    begin

    p:=1;

    read (a) ;

    if (a=0) then p:=0;

    while (a0) do begin

    s+=a;

    p*=a;

    read (a) ; end;

    writeln (s, ' ', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребят, помоги в паскале. напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. В конце работы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите алгоритм программы которая вводит числа с клавиатуры до тех пор пока не будет введено число 0. В конце работы вычислить сумму и произведение введенных чисел
Ответы (1)
Составьте схему алгоритма программы, которая будет осуществлять ввод чисел до тех пор, пока не будет введено число 17. Как только будет введено число 17, программа должна вывести количество введенных чисел
Ответы (1)
Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.
Ответы (1)
Помогите написать программы ... Задача 1 Напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры Задача 2 Напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран Задача 3
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)