Задать вопрос
10 июля, 23:05

Написать программу ввода целых чисел с клавиатуры, пока не будет введён 0

+2
Ответы (1)
  1. 10 июля, 23:44
    0
    {с клавиатуры вводится число a, до тех пор, пока не будет введен 0. Начальное введенное a записывается в min и max, чтобы потом в цикле было с чем сравнивать}

    var

    min, max, a:real;

    begin

    readln (a) ;

    min:=a; max:=a;

    while a0 do

    begin

    readln (a) ;

    if a>max then

    max:=a;

    if a
    min:=a;

    end;

    writeln ('min: ', min,' max: ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу ввода целых чисел с клавиатуры, пока не будет введён 0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Задание 1: Составьте программу ввода с клавиатуры массива целых чисел a[1 ... 10] и вывода на экран элементов массива с нечетными значениями. Задание 2:Составьте программу ввода с клавиатуры массива целых чисел a[1 ...
Ответы (1)
1) составьте программу ввода элементов массива а[1 ... 8 ] с клавиатуры и вывода на экран элементов с отрицательными значениями; 2) составьте программу ввода элементов массива b[1 ...
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Собери из суждений правильное умозаключение. №1 все устройства ввода служат для ввода информации. №2 клавиатура служит для ввода информации. №3 клавиатура устройство ввода
Ответы (1)