Задать вопрос
5 января, 06:52

Найти сумму элементов в двумерном массиве

+4
Ответы (1)
  1. 5 января, 08:09
    0
    Var

    i, j, n, m, sum:integer;

    a:array[1 ... 1000, 1 ... 1000] of integer;

    begin

    Readln (n, m) ;

    for i: = 1 to n do

    for j: = 1 to m do

    Read (a[i, j]) ;

    for i: = 1 to n do

    for j: = 1 to m do

    sum: = sum+a[i, j];

    Writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму элементов в двумерном массиве ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
В двумерном массиве 4 х3 найти количество элементов, больших - 5. Если таких элементов не оказалось - вывести сообщене "Таких элементов нет!". Элементы ввести с клавиатуры.
Ответы (1)
Информатика. Массивы. PascalABC. 1. В двумерном массиве 4 х5 вычислить сумму элементов кратных 3, значения которых больше 20. 2. Найти среднее арифметическое элементов главной диагонали квадратной матрицы 5 х5.
Ответы (1)