Задать вопрос
23 июля, 22:03

Воробей Джек прыгает по изгороди с колышка на соседний колышек. Каждый прыжок занимает у него 1 секунду. Он делает A прыжков вперед, потом B прыжков назад (B Формат ввода:

N A B

Пример ввода:

11 4 1

Формат вывода:

k - минимальное количество секунд

Пример вывода:

14

pascal

+4
Ответы (1)
  1. 23 июля, 22:30
    0
    Var

    ans, n, a, b, i, j:integer;

    begin

    Readln (n, a, b) ;

    i: = 1; ans:=0;

    while true do begin

    for j: = 1 to a do

    if i + j > n then break

    else ans: = ans + 1;

    i: = i + a;

    if i > = n then break;

    i: = i - b;

    ans: = ans + b;

    end;

    Writeln (ans) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Воробей Джек прыгает по изгороди с колышка на соседний колышек. Каждый прыжок занимает у него 1 секунду. Он делает A прыжков вперед, потом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Исполнитель "Стрелочка" умеет выполнять определенные команды: вперед, прыжок, направо, налево. Команда "вперед" перемещает стрелку и оставляет на поле черный след длинной в одну клетку, а команда "прыжок" перемещает стрелку на одну клетку, не
Ответы (1)
У белки было s1 орехов и s2 грибов. Она съела все грибы и s3 орехов. Сколько орехов у неё осталось? Формат ввода: s1 - количество орехов. s2 - количество грибов. s3 - количество съеденных орехов. Формат вывода: d - количество оставшихся орехов.
Ответы (1)
Дано слово. Записать каждый символ по два раза. Формат ввода: s - слово Формат вывода: s1 - новое слово Пример ввода: дождь Пример вывода: ддоожжддьь
Ответы (1)
Напишите программу, которая будет читать любую строку, а затем выводить ее на экран. Формат ввода: s - строка Формат вывода: s - строка Пример ввода: I am a string. Пример вывода: I am a string.
Ответы (1)
4. Исполнитель Кузнечик живет на числовой оси. Кузнечик может выполнять следующие команды: Вперед n (Кузнечик прыгает вперед на n единиц) ; Назад m (Кузнечик прыгает назад на m единиц), где переменные n и m - целые положительные числа.
Ответы (1)