Задать вопрос
21 июня, 22:31

Написать программу, которая вычисляет факториал числа.

+2
Ответы (2)
  1. 22 июня, 00:12
    0
    Var n, f, i: integer;

    begin

    write ('n = ') ;

    readln (n) ;

    f:=1;

    for i:=1 to n do f:=f*i;

    writeln (n,'! = ', f) ;

    end.

    Пример:

    n = 6

    6! = 720
  2. 22 июня, 01:31
    0
    Program E9;

    var p, i, n: integer;

    begin

    write ('введите целое n = ') ;

    readln (n) ;

    p: = 1;

    for i: = 1 to n do

    p: = p * i;

    write (n, '! = ', p) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая вычисляет факториал числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике