Задать вопрос
22 января, 23:04

Напишите программу, которая вычисляет факториал натурального числа N (1 ≤ N ≤ 10000), сохранив все значащие цифры. Факториалом называется произведение всех натуральных чисел от 1 до N : N! = 1·2·3 ... (N - 1) · N.

+2
Ответы (1)
  1. 23 января, 00:28
    0
    Program n1;

    var

    n, i: integer;

    p: real;

    begin

    write ('Введите n: ') ;

    readln (n) ;

    if (n>=1) and (n<=10000) then

    begin

    p : = 1;

    for i : = 2 to n do

    p : = p * i;

    writeln (n, '! = ', p) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая вычисляет факториал натурального числа N (1 ≤ N ≤ 10000), сохранив все значащие цифры. Факториалом называется ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Реализуйте рекурсивную функцию вычисления факториала натурального числа. Напоминаем, что факториалом числа называется произведение всех натуральных чисел, меньших или равных ему. К примеру, факториал 55 равен 5⋅4⋅3⋅2⋅15⋅4⋅3⋅2⋅1.
Ответы (2)
2. Составить программу, которая вычисляет количество чисел кратных 3, 4 и 5 одновременно в диапазоне от 1 до 1000. 3. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
С помощью repeat S = (x / (факториал) 1) + (х^2 / (факториал) 2) + (х^3 / (факториал) 3) + ... + (х^n / (факториал) n) + 0,0001
Ответы (1)
Задание: сделать функцию определения того, что данное число является факториалом: function reversef (f: integer; var n: integer) : boolean (возвращает true, если f - факториал, n - число, факториалом которого является f.
Ответы (1)