Задать вопрос
2 марта, 15:20

Напишите программу для Паскаля для перестановки максимального и минимального по значению элементов массива. Значения длины массива вводятся с клавиатуры

+2
Ответы (1)
  1. 2 марта, 15:53
    0
    Var a:array of integer;

    n, i, min, imin, max, imax:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    SetLength (a, n) ;

    for i:=0 to n-1 do

    begin

    a[i]:=random (51) ;

    write (a[i]:4) ;

    end;

    writeln;

    min:=a[0]; imin:=0;

    max:=a[0]; imax:=0;

    for i:=1 to n-1 do

    begin

    if a[i]
    begin

    min:=a[i]; imin:=i;

    end;

    if a[i]>max then

    begin

    max:=a[i]; imax:=i;

    end

    end;

    writeln ('min = ', min,' max = ', max) ;

    a[imin]:=max; a[imax]:=min;

    for i:=0 to n-1 do write (a[i]:4) ;

    writeln;

    end.

    Пример:

    n = 10

    33 17 33 49 3 2 14 25 35 47

    min = 2 max = 49

    33 17 33 2 3 49 14 25 35 47
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу для Паскаля для перестановки максимального и минимального по значению элементов массива. Значения длины массива вводятся ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите составить программу в Paskal! 1) Вычислите значение минимального элемента массива 2) Вычислите сумму минисального и максимального элементов 3) Выведите номер минимального элемента 4) Выведите номера максимальных элементов и их количество
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)