Задать вопрос
19 декабря, 13:50

Нкпишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчиващихся на 3

+5
Ответы (1)
  1. 19 декабря, 16:31
    +1
    var n, i, s, a: integer;

    begin

    readln (n) ;

    s:=0;

    for i:=1 to n do begin

    readln (a) ;

    if (a div 7 0) and (a mod 10 = 3) then

    s:=s+a;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нкпишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчиващихся на 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (2)
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегдаимеется число, кратное 6.
Ответы (1)