Задать вопрос
10 февраля, 12:07

Попугай Рома вытягивает каждый из семи дней случайным образом число от 1 до 10. Сколько чётных и сколько нечётных чисел он вытянул за неделю.

+1
Ответы (1)
  1. 10 февраля, 14:18
    0
    Var

    i, kn, m:integer;

    begin

    Randomize;

    kn:=0;

    for i:=1 to 7 do begin

    m:=Random (10) + 1;

    Write (m,' ') ;

    if m mod 2 0 then kn:=kn+1

    end;

    Writeln;

    Writeln (kn,' нечетных, ',7-kn,' четных')

    end.

    Пример

    8 4 7 9 4 5 10

    3 нечетных, 4 четных
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Попугай Рома вытягивает каждый из семи дней случайным образом число от 1 до 10. Сколько чётных и сколько нечётных чисел он вытянул за ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
Костя, Рома и Витя занимаются лыжами, футболом и боксом. Рома не любит лыжи, а Витя не занимается ни лыжами, ни боксом. Какой спорт выбрал Рома? Футбол Неизвестно Бокс Лыжи 2. Костя будущий ... Футболист Лыжник Неизвестно Боксер 3.
Ответы (2)
Кто-то из троих детей в доме откусил кусочек торта, не дождавшись гостей. Мама спросила: "Кто это сделал?" Света сказала, что это был Рома, а не она. Дима сказал, что это Света, а не Рома. И Рома подтвердил, что это не он, и не Дима.
Ответы (1)
Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных.
Ответы (1)