Задать вопрос
19 декабря, 18:18

Дано трехзначное число. Определить, является ли сумма его цифр кратна 3 и 5. Написать программу на C + + и Pascal

+5
Ответы (1)
  1. 19 декабря, 20:44
    0
    C++

    #include

    using namespace std;

    int main ()

    {

    int n = 0;

    cout << "Enter num: ";

    cin >> n;

    if (n > = 100 && n < = 999) {

    int s = (n / 100) + ((n / 10) % 10) + (n % 10) ;

    if (s % 3 = = 0) {

    cout << "Num multiple 3" << endl;

    } else {

    cout << "Num not multiple 3" << endl;

    }

    if (s % 5 = = 0) {

    cout << "Num multiple 5" << endl;

    } else {

    cout << "Num not multiple 5" << endl;

    }

    } else {

    cout << "Error!" << endl;

    }

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано трехзначное число. Определить, является ли сумма его цифр кратна 3 и 5. Написать программу на C + + и Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Написать программу "Выделение цифр в записи числа" Дано трехзначное число. Определить, является ли сумма его цифр кратна 3 и 5.
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
Дано двузначное числи. Определит. А) кратна ли трем сумма его цифр Б) кратна ли сумма его цифр числу a.
Ответы (1)