Задать вопрос
26 ноября, 11:11

Нужно написать программу на pascal. Даны натуральное число n и вещественные числа а1, а2, а3, ..., аn. Определить сумму квадратов вещественных чисел.

+2
Ответы (1)
  1. 26 ноября, 12:50
    0
    Var

    i, n:integer;

    s, t:real;

    begin

    Write ('n=') ; Readln (n) ;

    s:=0;

    for i:=1 to n do begin

    Read (t) ;

    s:=s+t*t

    end;

    Writeln ('Сумма квадратов равна ', s)

    end.

    Пример

    n=5

    -23.1 42.6 146 0 0.12

    Сумма квадратов равна 23664.3844
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно написать программу на pascal. Даны натуральное число n и вещественные числа а1, а2, а3, ..., аn. Определить сумму квадратов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
В питоне Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b).
Ответы (1)
Даны вещественные числа a, b, c. Выяснить, имеет ли уравнение ах2 + bx + c = 0 вещественные корни. Написать программу!
Ответы (1)