Задать вопрос
29 мая, 12:59

Дано число если даное число нечотное то умножить на 2 если даное число больше 7-ми то вычислить квадратный корень

+5
Ответы (1)
  1. 29 мая, 13:08
    0
    Паскаль:

    var a:integer; begin ReadLn (a) ; if not (a mod 2 = 0) then WriteLn (a*2) ; if a > 7 then Writeln (Sqrt (a)) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано число если даное число нечотное то умножить на 2 если даное число больше 7-ми то вычислить квадратный корень ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу - калькулятор, которая запрашивает тип математической функции: 1-квадрат, 2-куб, 3 - корень квадратный, 4 - обратная функция, а также аргумент функции x и вычисляет для x соответствующую математическую функцию.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Это цикл for: 1) даны натуральные числа X и Y. вычислить X*Y, пользуясь только оперцией сложения. 2) даны натуральные числа X и Y. вычислить X^Y 3) дано натуральное число N. найти сумму S=1+1/2+1/3 + ... + 1/N. 4) дано натуральное число N и число Х.
Ответы (1)
Паскаль. 1 дано целое число N. Вычислить среднее арифметическое всех чисел из диапазона от 1 до N. 2 дано целое число N. Вывести на экран все нечётные числа из диапахона от 1 до N. Вычислить их сумму.
Ответы (1)
Написать программу в паскале 1. Вычислить сумму и произведение n первых членов арифметической прогрессии: а1=2; d=3; an=an-1+d. 2, дано натуральное число n. Вычислить (1+1/12)  (1+1/22)  ... (1+1/n2). 3. Дано целое число А.
Ответы (1)