Задать вопрос
31 декабря, 03:48

9 класс! Напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - при знак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму чётных чисел.

+2
Ответы (1)
  1. 31 декабря, 04:47
    0
    Var a, n, s:integer;

    begin

    n:=0; s:=0;

    readln (a) ;

    while a0 do

    begin

    n:=n+1;

    if a mod 2=0 then s:=s+a;

    readln (a) ;

    end;

    writeln ('n = ', n,' s = ', s) ;

    end.

    Пример:

    5

    2

    8

    7

    3

    0

    n = 5 s = 10
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «9 класс! Напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел. Программа получает на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (признак окончания ввода,
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3. Программа получает на вход целые числа.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Прошу Помогите я вам буду очень благодарен! Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)