Задать вопрос
20 сентября, 19:47

Написать программу для подсчета суммы

введенных с клавиатуры чисел до тех пор, пока не будет

введен 0.

+5
Ответы (1)
  1. 20 сентября, 20:07
    0
    Var a, s:integer;

    begin

    s:=0;

    readln (a) ;

    while a0 do

    begin

    s:=s+a;

    readln (a) ;

    end;

    writeln ('s = ', s) ;

    end.

    Пример:

    5

    8

    3

    4

    6

    0

    s = 26
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для подсчета суммы введенных с клавиатуры чисел до тех пор, пока не будет введен 0. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Цикл с пост условием! помогите Написать программу которая будет вводить целые числа до тех пор пока не будетвведён 0. Подсчитать количество положительных и отрицательных чисел.
Ответы (1)
С клавиатуры пользователь вводит числа до тех пор, пока не будет введен 0. вычислите сумму введенных чисел
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Осуществить ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых положительных чисел. Использовать оператор repeat.
Ответы (1)