Задать вопрос
24 февраля, 02:37

Напишите программу подсчитывающая количество минимальных элементов в заданном массиве

+2
Ответы (1)
  1. 24 февраля, 06:20
    0
    Program glg;

    var

    a:array[1 ... 10] of integer;

    min, kol: integer;

    begin

    i : = 0;

    kol:=0;

    min: = 100000;

    while i < 10 do

    begin

    readln (a[i]) ;

    if a[i] < min then min: = a[i];

    end

    i:=0;

    while i < 10 do

    if a[i] = min then kol = kol + 1;

    writeln (kol) ;

    end.

    Если ошибки будут, пишите в комментарии. Я с телефона писал, мог где-нибудь, да ошибиться. (Написано на Pascal)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу подсчитывающая количество минимальных элементов в заданном массиве ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
В произвольно заданном одномерном1. В произвольно заданном одномерном массиве (случайные значения из отрезка - 4 до 10) из 13 элементов, определить минимальный элемент и его номер. 2.
Ответы (1)
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов. Известно, что в массиве есть хотя бы один нечетный элемент.
Ответы (1)