Задать вопрос
28 декабря, 16:16

Дан массив Z[1 ... 4,1 ... 3] с целыми элементами. Создать программу с процедурой которая вычислит количество отрицательных чисел и сумму нечетных элементов массива

+2
Ответы (1)
  1. 28 декабря, 20:15
    0
    Если программа нужна на паскале, то вот держите

    program ArrayZ;

    uses CRT; / / Подключение модуля CRT

    var z: array[1 ... 4, 1 ... 3] of integer; / / Массив i, j, n, o: integer; / / Переменные для циклов и счета отрицательных и нечетных элементов

    begin randomize; / / Нужно для turbopascal / / Заполнение массива for i : = 1 to 4 do begin writeln; / / Переход на другую строку for j : = 1 to 3 do begin z[i, j] : = random (60) - 30; / / Рандомное заполнение массива write (z[i, j]:8) ; / / Вывод в консоль массива end; end; / / Нахождение отрицательных и нечетных элементов for i : = 1 to 4 do for j : = 1 to 3 do begin if z[i, j] mod 2 0 then / / Нахождение нечетных элементов n : = n + 1; if z[i, j] < 0 then / / Нахождение отрицательных элементов o : = o + 1; end; writeln; / / Переход строки чтобы не было конфликтов writeln ('Нечетных элементов: ', n, ' | Отрицательных элементов: ', o) ; / / Вывод результатаend.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив Z[1 ... 4,1 ... 3] с целыми элементами. Создать программу с процедурой которая вычислит количество отрицательных чисел и сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)