Задать вопрос
7 апреля, 10:27

Задача:

Подсчитать сумму 1! + 2! + 3! + ... N!

Где, например, 5! - - факториал числа 5 и 5! = 1*2*3*4*5

Формат ввода:

На вход подается натуральное число n не превосходящих 10.

Формат вывода:

Целое число - результат вычисления формулы.

Пример входных данных

5

Пример выходных данных

153

+5
Ответы (1)
  1. 7 апреля, 13:48
    0
    Function Factorial (N: integer) : integer;

    var i, R: integer;

    begin

    R : = 1;

    For i: = 1 to N do

    R : = R * i;

    Factorial : = R;

    end;

    Var

    N, i, S: integer;

    Begin

    ReadLn (N) ;

    S : = 0;

    For i: = 1 to N do

    S : = S + Factorial (i) ;

    WriteLn (S) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача: Подсчитать сумму 1! + 2! + 3! + ... N! Где, например, 5! - - факториал числа 5 и 5! = 1*2*3*4*5 Формат ввода: На вход подается ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите на пасхале Задача: Найти количество четных цифр натурального числа. Формат ввода: На вход подается натуральное, не превосходящее 30000. Формат вывода: Целое число. Пример входных данных 321 Пример выходных данных 1
Ответы (1)
С некоторого момента прошло N дней. Сколько полных недель прошло за этот период. Формат входных данных На вход программе подается 0≤N≤106. Формат выходных данных Вывести целое число - ответ на вопрос. Примеры: Вход 100 Выход 14
Ответы (1)
Напишите рекурсивную функцию вычисления суммы цифр натурального числа. Формат входных данных На вход ваша программа получает одно натуральное число n (n
Ответы (1)
Формат входных данных: Дано целое число A и натуральное число i. Формат выходных данных: Обнулите у числа A его последние i бит и выведите результат обнуления. Помогите скорей, кто понимает, о чём идет речь!
Ответы (1)
Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём. Формат входных данных Вводится целое число n (100≤n≤999) Формат выходных данных Требуется вывести сумму и произведение его цифр через пробел.
Ответы (1)