Задать вопрос
24 февраля, 17:09

В Паскале. Дан массив Z размером 9, заполненный из промежутка (3 ... 9). Заменить все нечетные элементы на их номера.

+4
Ответы (1)
  1. 24 февраля, 17:20
    0
    Var

    z:array[1 ... 9]of integer;

    i:integer;

    begin

    randomize;

    for i: = 1 to 9 do

    begin

    z[i]: = 3 + random (7) ;

    write (z[i], ' ') ;

    end;

    for i: = 1 to 9 do

    if i mod 2 = 1 then

    z[i] : = i;

    Writeln;

    for i: = 1 to 9 do

    write (z[i], ' ') ;

    end.

    Пример:

    4 4 5 6 8 4 3 5 5

    1 4 3 6 5 4 7 5 9
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В Паскале. Дан массив Z размером 9, заполненный из промежутка (3 ... 9). Заменить все нечетные элементы на их номера. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Дан массив целых чисел a (n) (n=15) заполненный случайным образом числами из промежутка [-20,50]. Заменить единицей все нечетные по значению элементы данного массива.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
Помогите, надо написать программу на паскале 1. Дан одномерный массив, заполненный по правилу: каждый элемент равен удвоенному порядковому номеру. Заменить элементы, стояшие на четных местах на нули. Распечатать полученный массив. 2.
Ответы (1)