Задать вопрос
14 августа, 13:40

Помогите, надо написать программу на паскале

1. Дан одномерный массив, заполненный по правилу: каждый элемент равен удвоенному порядковому номеру. Заменить элементы, стояшие на четных местах на нули. Распечатать полученный массив.

2. Двумерный массив задан с клавиатуры. Найти произведение элементов, выше главной диагонали.

+4
Ответы (1)
  1. 14 августа, 14:10
    0
    первая часть

    Program TZ5;

    const

    n=10;

    var

    a:array [1 ... n] of integer;

    i, b:integer;

    begin

    for i:=1 to n do begin

    a[i]:=i*2;

    writeln (i,' ', a[i]) ;

    end;

    for i:=1 to n do

    if (i mod 2) = 0 then

    a[i]:=0;

    writeln ('novuy massiv') ;

    for i:=1 to n do

    writeln (i,' ', a[i]) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите, надо написать программу на паскале 1. Дан одномерный массив, заполненный по правилу: каждый элемент равен удвоенному порядковому ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)