Задать вопрос
13 апреля, 19:33

Составить программу подсчета кол-ва положительных отрицательных чисел в произвольном числовом ряду

Помогите решить в Паскале

+5
Ответы (1)
  1. 13 апреля, 21:23
    0
    Program n_1;

    uses crt;

    var a: array [1 ... 5] of integer;

    otr, pol, i: byte;

    begin

    for i:=1 to 5 do begin

    a[i]:=random (10) - 5;

    write (a[i]:3) ;

    if a[i]>0 then pol:=pol+1 else

    if a[i]<0 then otr:=otr+1;

    end;

    writeln;

    writeln ('Положительных: ', pol,'; Отрицательных: ', otr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу подсчета кол-ва положительных отрицательных чисел в произвольном числовом ряду Помогите решить в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)
Ребят, помогите с задачей. Напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 элементов. Если отрицательных элементов нет, то сообщить об этом) p. s. В паскале
Ответы (1)
1. Разработать программу алгоритма для подсчета количества отрицательных чисел среди целых чисел a, b, c. Протестировать алгоритм для всех возможных случаев (когда количество отрицательных чисел равно 0, 1, 2 и 3). 2.
Ответы (1)
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)
Определить среди 3 введенных чисел (a, b, c) количество отрицательных и положительных. Если больше положительных, то найти минимум из этих 3 чисел, а иначе найти максимум. (нужно нарисовать блок схему и написать программу в паскале)
Ответы (1)