Задать вопрос
15 апреля, 12:33

Написать программу (в Pascal), которая определяет полную поверхность 30-ти шаров. Радиус первого составляет 59 м, а каждого последующего уменьшается на 1 м.

+5
Ответы (1)
  1. 15 апреля, 13:20
    0
    Блок-схема - в прилагаемом файле.

    var r:integer; s:real;

    begin

    s:=0;

    for r:=59 downto 30 do

    s:=s+4*pi*r*r;

    writeln ('s = ', s:10:3) ;

    end.

    Результат:

    s = 774779.580
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу (в Pascal), которая определяет полную поверхность 30-ти шаров. Радиус первого составляет 59 м, а каждого последующего ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)