Задать вопрос
18 ноября, 18:51

Составить программу для данного условия: Вычисление суммы только положительных чисел из последовательно введенных чисел (остановить обработку при 100.0). В Паскале

+2
Ответы (2)
  1. 18 ноября, 21:53
    0
    Var a, s:real;

    begin

    s:=0;

    repeat

    readln (a) ;

    if a>0 then s:=s+a;

    until s>=100;

    writeln ('s = ', s:5:1) ;

    end.

    Пример:

    45

    -84

    12

    30

    -30

    53

    s = 140.0
  2. 18 ноября, 22:14
    0
    Вычисление суммы только положительных чисел из последовательно введенных чисел (остановить обработку при 100.0)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для данного условия: Вычисление суммы только положительных чисел из последовательно введенных чисел (остановить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определить среди 3 введенных чисел (a, b, c) количество отрицательных и положительных. Если больше положительных, то найти минимум из этих 3 чисел, а иначе найти максимум. (нужно нарисовать блок схему и написать программу в паскале)
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)
Задача в паскале среди 10 введенных с клавиатуры чисел подсчитать количество отрицательных и произведение положительных чисел рассмотреть случай когда положительных чисел нет
Ответы (1)
Написать программу в Паскале. Используя операторы цикла и условия, написать программу, которая из введенных N чисел: 1) Находит и выводит на экран все двухзначные числа, кратные 10 (с циклом mod). 2) Найти сумму всех чисел больше 10.
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)