Задать вопрос
4 апреля, 19:54

Решите задачу на языке Pascal.

Дано 3 числа. Найти суму двух наибольших из них.

+2
Ответы (1)
  1. 4 апреля, 23:48
    0
    Var a, b, c, max, two: Integer;

    begin

    writeln ('Введите 1 число') ;

    readln (a) ;

    writeln ('Введите 2 число') ;

    readln (b) ;

    writeln ('Введите 3 число') ;

    readln (c) ;

    max:=a;

    if max < b then max:=b;

    if max < c then max:=c;

    if max=a then

    begin

    two:=max;

    if c < b then two:=b;

    if c > b then two:=c;

    writeln (max,'+', two,'=', max+two) ;

    end;

    if max=b then

    begin

    two:=max;

    if c < a then two:=a;

    if c > a then two:=c;

    writeln (max,'+', two,'=', max+two) ;

    end;

    if max=c then

    begin

    two:=max;

    if a < b then two:=b;

    if a > b then two:=a;

    writeln (max,'+', two,'=', max+two) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решите задачу на языке Pascal. Дано 3 числа. Найти суму двух наибольших из них. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Результаты поиска для фразы "четверо друзей во время путешествие одалживали друг у друга деньги используя доблицу долгов опредилите кто из ребят во время раздачи долгов получит наибольшую суму" Результаты поиска для фразы "четверо друзей во время
Ответы (1)
Вася изучал сегодня на информатике тему "Рекурсия". После урока на доске осталась такая функция (для условия на языке Pascal - процедура) : на языке Python: def f (n) : print ('*') if n > 2: f (n - 1) f (n - 2) на языке Pascal: procedure f (n:
Ответы (1)